Your server's version of PHP (5.3.8) is too old to run Elgg.